Fenêtre active pas au prmier plan

Le Forum Windows 10
Scanner Windows pour détecter les erreurs de registre

Ce que nous vous conseillons :

1. Lisez les réponses ci-dessous où vous trouverez des conseils et de l'aide de la part des autres utilisateurs.

2. Avant de faire des modifications sur votre système ou d'installer des logiciels, nous vous recommandons
    fortement de cliquer ici pour scanner Windows afin de détecter les erreurs de registre.



Fenêtre active pas au prmier plan

Messagepar molo2003 » 03 Juil 2017, 17:28

Bonjour;
je roule sous W10 Famille version 1703 sur PC avec I5. je suis sous W10 depuis une petite année.
Je ne eux pas faire un rapprochement direct avec W10 mais je vous fais part d'une constatation gênante pour l'utilisation de mon PC.
Depuis plusieurs mois, ce constat est fait: comme j'ouvre plusieurs fenêtres sous W10 (thunderbird, Firefox, Explorer, Visual Studio 17, ... Open Office Writter ...), bref une utilisation normale pour un PC. Dans ces conditions, la fenêtre active ne reste pas au premier plan, mais s'affiche derrière d'autres ...puis elle apparaît mais disparait aussitôt ... si bien que pour travailler sereinement, je suis obligé de mettre en "icone" toutes fenêtres non actives pour garder la seule fenêtre active à l'écran. Depuis longtemps j'utilise le PC, et jamais je n'avais constaté ce phénomène ...
A votre avis, existe-il un paramètre dans W10 qui pourrait supprimer ce dysfonctionnement ??? Ou encore le fonctionnement de la souris .... il suffirait que la souris survole une fenêtre pour la rendre active ??? Je pense que c'est dans ces paramètres (souris) là qu'il faut chercher... Avez-vous une idée ???
Dans "Paramètres" "Options d'ergonomie" puis "souris", à part le dimensionnement du pointeur, je n'ai comme paramètre possible que "Utiliser le clavier numérique pour déplacer la souris" lequel est déactivé.
Merci d'avance de votre aide
molo2003
 
Messages: 11
Inscrit le: 26 Aoû 2011, 15:07

Re: Fenêtre active pas au prmier plan

Messagepar Jouvassine » 04 Juil 2017, 11:24

Bonjour.

Appuyer sur les touches WINDOWS et R
Taper regedit.exe ─► OK
Dans le registre, déployer cette branche :
HKEY_CURRENT_USER\Control Panel\Desktop\
Clic droit sur la clé Desktop ─► Exporter
Sélectionner le dossier Documents
Sauvegarder sous le nom de Windows_on_top
Si la manipulation qui va suivre ne fonctionne pas, il suffira de cliquer sur ce fichier pour tout remettre en ordre.
Dans le panneau de droite, clic droit sur ForegroundLockTimeout ─► Modifier
Mettre comme données 0 (zéro).
Jouvassine
 
Messages: 178
Inscrit le: 14 Aoû 2016, 09:50

Re: Fenêtre active pas au prmier plan

Messagepar molo2003 » 05 Juil 2017, 07:29

Merci Jouvassine de ta réponse;
Pour l'instant je n'ai rien fait, car j'aimerai comprendre avant de faire.
Modifier le registre ne me pose pas de problème (faut être méticuleux et prudent).
Explique moi le fonctionnement de ce paramètre "ForegroundLockTimeout" sur le "focus des fenêtres" ???
A l'origine , il est a "200000 millisecondes". A quoi sert-il ? Comment s'applique t-il ? 200 secondes c'est énorme ... je ne comprends pas à quoi sert-elle ??? La mettre à zéro pourquoi ???
Avec cette valeur jamais changée, cela fonctionnait bien dans les versions précédentes de Windows.
Sais-tu si Microsoft valide cette modification ???
Si tu peux me renseigner
Merci d'avance
molo2003
 
Messages: 11
Inscrit le: 26 Aoû 2011, 15:07

Re: Fenêtre active pas au prmier plan

Messagepar molo2003 » 05 Juil 2017, 09:51

Re bonjour à Jouvassine;
Pour te faire part de ce que j'ai fait:
1) j'ai modifié le registre avec "zéro" dans la clef "ForegroundLockTimeout". J'ai redémarré le PC.
Résultat: aucun effet .... "Le canard est toujours vivant !" je vais remettre le paramètre à sa valeur initiale (200000 ms).
2) J'ai constaté ce phénomène: quand je glisse la souris sur plusieurs fenêtres, celle qui s'affiche en premier plan est celle où se trouve la souris. Elle devient active alors que je n'ai pas cliqué à gauche pour la sélectionner.
La présence de la souris sur une fenêtre la rend active et s'affiche à l'écran en totalité. Si je clicque a gauche, elle reste bien mais si je déplace ma souris sur la voisine, la voisine va s'ouvrir.
Je pensais que cela pouvait venir de ma souris. Actuellement, j'utilise une souris sans fil. Avec une souris filaire j'ai la même anomalie. J'ai regardé dans "Paramètres" "Périphériques" "Souris" et "Options supplémentaires de la souris": rien d'anormal.
Donc pour travailler confortablement, je suis obligé de mettre en icone toutes les fenêtres inactives et garder celle sur laquelle je travaille.
Merci d'avance de votre aide
molo2003
 
Messages: 11
Inscrit le: 26 Aoû 2011, 15:07


Retour vers Windows 10

Qui est en ligne ?

Utilisateurs parcourant actuellement ce forum : Aucun utilisateur inscrit et 3 invités

  •  Liens commerciaux



cron