Fuite de mémoire + fermeture excessivement lente

Le Forum Windows XP

Fuite de mémoire + fermeture excessivement lente

Messagepar Luciole » 27 Mar 2010, 16:58

Bonjour,

Je possède un Dell (Latitude 620) avec Windows XP installé dessus. J'ai dernièrement effectué un formatage et j'ai à présent un gros problème de fuite mémoire (du moins je pense) : après environ 2 heures de marches, une notification m'informe que Windows étend sa zone de mémoire virtuelle, et plus aucun programme n'arrive à tourner quelques heures plus tard (ils n'arrivent plus à accéder à la mémoire nécessaire je pense). Lorsque j'éteind mon pc, il met beaucoup de temps pour se couper (explorer se coupe puis Windows reste 5 - 10 minutes sur le fond d'écran seul).

C'est de loin mon premier formatage Dell-XP, mais c'est la première fois que ça m'arrive. Je n'ai aucune idée de ce que je peux faire, quelqu'un pourrait s'il-vous-plait m'aider ?

P.S. : j'ai déjà essayer le reformatage, ça ne marche pas
Luciole
 
Messages: 5
Inscrit le: 27 Mar 2010, 16:32

Re: Fuite de mémoire + fermeture excessivement lente

Messagepar AbraCarambar » 27 Mar 2010, 18:00

Salut,
Bienvenu au club des DELL, sur latitude aussi E6500 :wink:
quand tu as réinstallé, tu as bien mis les drivers dans le bon ordre?

Avant toute chose, tu vas faire un reset bios de la bête: (remet le bios par défaut, sans flash, mais décharge aussi tout composant d'une éventuelle électricité statique qui perturberait l'un des composants)
procédure simple: tu retires la batterie et le secteur, puis tu restes appuyé 30 s sur le bouton "power". puis tu repars.
ce reset bios est magique, j'ai permis d'ajouter plus d'un résolu avec cette manip, et partant de problèmes les plus variés.

J'ai l'impression que c'est en effet la RAM qui déconne, ce serait bien de tester ta bête/
deux choses:
1- memtest86 pour tester la RAM, LeLapinFou est calé pour l'analyse de ce test, et il lit tout ici, il pourra te conseiller. si le test passe à 100%, la RAM est bonne.
2- Au démarrage, tu fais F12 sur l'écran DELL, plusieurs fois rapidement pour être sûr de presser la touche au bon moment, puis tu lances la partition diagnostics, qui va tester tout le hard. Prends le test complet et suis bien à l'écran si tout "pass". Il va tester tout le hard, y compris la RAM. double test donc.

Pour les manips du registre, démarrer/exécuter, taper regedit, tu vas entrer dans la base.
première manip à faire: fichier/exporter, puis tu exportes ta base, tu vas créer un fichier .reg qui te permettra avec un double clic dessus de ramener ta base à ce moment de sauvegarde.

Ensuite, pour la fermeture lente, y'a des clés de registre à modifier: (modif sans risque puisque tu auras une sauvegarde)

Taper regedit dans démarrer/exécuter, puis

1- Pour accélérer la procédure de fermeture des applications :
Sélectionnez cette clé: HKEY_CURRENT_USER\ControlPanel\Desktop

Ensuite sur le panneau de droite, recherchez la valeur chaîne "WaitToKillAppTimeout" et donnez-lui la valeur de 200 (20000 par défaut je crois)
La valeur correspond au temps nécessaire, en millisecondes, avant de forcer la fermeture de l'application.
Faire pareil pour la valeur chaîne "HungAppTimeout"

Créez une nouvelle valeur chaîne et donnez-lui le nom "AutoEndTasks", puis donnez-lui valeur 1

2- Pour accélérer la procédure de fermeture des services :
Sélectionnez la clé: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

Créer une nouvelle valeur chaîne : menu Édition > Nouveau > Valeur DWORD, et nommez cette valeur WaitToKillServiceTimeout, puis donnez-lui comme valeur 200
La valeur correspond au temps nécessaire, en millisecondes, avant de forcer la fermeture du service.

voilà pour les modifs du registre à changer, ou créer, qui permettront d'accélérer cela.
AbraCarambar
 

Re: Fuite de mémoire + fermeture excessivement lente

Messagepar Luciole » 27 Mar 2010, 21:43

Salut,

J'ai fais tous les tests et les modifications conseillés.

Niveau hardware, tout semble bien aller (et mon ordinateur tourne d'ailleurs sans problèmes sous Ubuntu). J'avais acheter ma RAM actuelle mi-novembre, ça m'aurait fait mal qu'elle soit déjà morte ^^

J'ai modifié les registres, mais ça ne change rien.

Je soupconne les drivers être à l'origine de mon problème car c'est après leur installation que ça a commencé à déconner (même si j'ai respecté scrupuleusement l'ordre d'installation indiqué sur le site).

J'aurais bien aimé pouvoir me servir de windows sur ce pc, mais ce n'est pas grave si j'en fait un pc majoritairemet linux, j'en ai un autre pour Windows :)

Merci pour votre aide en tout cas !!
Luciole
 
Messages: 5
Inscrit le: 27 Mar 2010, 16:32

Re: Fuite de mémoire + fermeture excessivement lente

Messagepar AbraCarambar » 27 Mar 2010, 22:23

ok, c'est pour cela que je te demandais si les drivers avaient été installés dans l'ordre.

Si tu penses que les pilotes sont la raison de ces bugs, il faut dans ce cas remettre XP, et installer les drivers du site de DELL dans l'ordre préconisé: je vais voir sur ton pc ce que je ferais.


1. Desktop System Software (DSS, Logiciel pour ordinateur de bureau) ou Notebook System Software (NSS, Logiciel pour ordinateur portable) tu peux te passer de cela, aucun problème. de plus, les maj de DELL ont planté certains pc, à toi de voir.

2. Chipset CM intel: crucial, à ne pas zapper

3. Carte vidéo : nvidia si tu as une CG séparée ou Intel si tu n'as pas pris de CG séparée. crucial

4. Carte d'interface réseau: à mettre avant le quickset ou DCP, précaution

5. Dell Quickset ou gestionnaire Dell Control Point (DCP): seul soft de DELL que je mets sur les pcs

6. pilote Carte audio

7. Modem: un truc que je ne mets pas car cela ne sert plus.

8. Carte réseau sans fil: prendre le pilote qui correspond à ta carte.

9. Pavé tactile, pointeur, bouton de pointage, souris et claviers: l'ordre n'est pas important pour ces derniers.

10. Autres périphériques
* Vous trouverez le pilote de module Bluetooth® ® dans la catégorie Réseau de la page Pilotes et téléchargements.
* Vous trouverez le pilote des cartes haut débit mobiles sans fil Dell dans la catégorie Communication de la page Pilotes et téléchargements.
* Vous trouverez le pilote des contrôleurs PCMCIA/Smartcard dans la catégorie Sécurité de la page Pilotes et téléchargements.

Donc si tu respectes cela, que le pc n'a pas de soucis matériel, aucune raison que cela ne marche pas. Et surtout, bien redémarrer entre chaque installation de pilote.
Ne mets rien de plus que les pilotes, y'a plein d'applications chez DELL qui sont utiles pour les pcs en entreprise, mais pas pour les particuliers. Donc tu ne mets que les pilotes machines, aucune application, si ce n'est quickset. Pour le DCP, à voir.

Si tu as le DCP sur ta machine, attention, cet outil est hyper capricieux, y'a un ordre pour l'installer, et je t'avoue que je ne le remettrai pas sur ma prochaine install Il m'en a fait beaucoup voir cet outil là. Ses fonctionnalités sont limitées, et ce soft prend une place dingue.
en revanche, si tu as le quickset, c'est indispensable de la mettre.

voilà, n'hésites pas si tu as des questions.
AbraCarambar
 

Re: Fuite de mémoire + fermeture excessivement lente

Messagepar Luciole » 28 Mar 2010, 09:33

Ok merci, j'avais déjà suivi à la lettre les conseils indiqués ici : http://support.euro.dell.com/support/topics/topic.aspx/emea/shared/support/downloads/fr/driver_install_order?c=fr&cs=frdhs1&l=fr&s=dhs&~lt=print, mais il faut croire qu'il y a un problème avec un des drivers. Je voulais écarter les causes hardware et Windows. Je ferai un petit formatage quand je serai moins pressé par le temps ^^

Bonne journée !!
Luciole
 
Messages: 5
Inscrit le: 27 Mar 2010, 16:32

Re: Fuite de mémoire + fermeture excessivement lente

Messagepar AbraCarambar » 28 Mar 2010, 10:19

Yep,
ce que font les techniciens, ils mettent le pilote CM et le pilote CG, et ensuite vont voir le gestionnaire des périphs, si tout est ok, et bien autant laisser windows gérer.
Pour le NSS, ou DSS, tu peux donc t'en passer.

Cela te permettra de voir ensuite, au goutte à goutte, le pilote qui pose problème, si tu en rajoutes. Sur ma machine, je mets le pilote CM, celui de la CG, celui de la carte son, et du pad, et c'est tout. Et tout fonctionne à merveilles.

Très étonnant, voire impossible qu'un pilote ne passe pas, ces pilotes du site de DELL sont certifiés fonctionnant.
Ils ne sont pas à jour, mais ils fonctionnent.
voilà, bon formatage quand tu auras le temps donc et bon dimanche.
AbraCarambar
 


Retour vers Windows XP

Qui est en ligne ?

Utilisateurs parcourant actuellement ce forum : BingBot [Bot], Google [Bot] et 9 invités

  •  Liens commerciaux