Excel 2007 : Problème qui n'existait pas sous Excel 2003

Le Forum Windows XP

Messagepar didpoy » 13 Aoû 2007, 13:10

Hello

J'utilise un fichier excel sous excel 2007 et j'ai dans ma case résultat le message suivant: #VALEUR!

Sous excel 2003, je n'avais pas ce message !!!!

Cela vient d'une formule qui tente d'additionner une case vide "" et je pense que sous 2007 une case vide n'est pas assimilée à la valeur zéro !!!!

j'ai tenté de configurer excel 2007 mais pas moyen de lu ifaire admettre que la case vide = 0 et pas moyen de faire disparaitre : #VALEUR! alors que le principe fonctionne dés que je mets une valeur là où il faut ...

Que faire sans modifier les formules car si je remplace la formule : =SI(C2="";"";C2/2) par =SI(C2="";0;C2/2) cela fonctionne et #VALEUR! disparait mais mes cases vides affichent 0 et je veux que les cases non utilisées restent vides sans 0.

Voici le lien en exemple: http://www.megaupload.com/?d=H7O6AZFF

Merci de votre aide à tous

Bye

;)
didpoy
 
Messages: 24
Inscrit le: 02 Aoû 2005, 19:55

Messagepar Kejin » 13 Aoû 2007, 13:47

Bonjour,

Il te suffit d'ajouter une confition supplémentaire dans ta formule.
En effet, dans la formule de la cellule G2 de ton exemple, tu peux spécifier que si la cellule F2 est vide, alors il considère que la valeur est 0, sinon il prend la valeur de la cellule.

Voici la syntaxe : =SI(E2="";"";(N1-E2)+SI(F2="";0;F2))
Ce que vous appelez l'enfer, Rambo il appelle ça chez lui...
Avatar de l’utilisateur
Kejin
Modérateur
 
Messages: 4651
Inscrit le: 31 Oct 2004, 11:59

Messagepar didpoy » 13 Aoû 2007, 14:27

re

Merci pour l'info.

Donc je dois adapter mes formules ...

Bizarre que sous 2003 cela ne le faisiat pas !!!!

Mais bon

Merci

bye

:)
didpoy
 
Messages: 24
Inscrit le: 02 Aoû 2005, 19:55

Messagepar Kejin » 13 Aoû 2007, 16:21

pas de quoi, même si c'est plus une ruse de sioux :P
Ce que vous appelez l'enfer, Rambo il appelle ça chez lui...
Avatar de l’utilisateur
Kejin
Modérateur
 
Messages: 4651
Inscrit le: 31 Oct 2004, 11:59

Messagepar didpoy » 17 Aoû 2007, 16:05

Re

Bizarre tout de même que la cellule ne soit pas considérée à zéroquand elle vide !!!!

Sur les versions antérieures cela fonctionne sans problème !!!!

Il doit y avoir un paramètre dans office 2007 à modifier pour empêcher cet affichage , NON ?

Merci

Bye

;)
didpoy
 
Messages: 24
Inscrit le: 02 Aoû 2005, 19:55

Messagepar Kejin » 17 Aoû 2007, 18:01

c'est fort possible mais j'avoue que je ne sais pas où ça se cache...
Ce que vous appelez l'enfer, Rambo il appelle ça chez lui...
Avatar de l’utilisateur
Kejin
Modérateur
 
Messages: 4651
Inscrit le: 31 Oct 2004, 11:59


Retour vers Windows XP

Qui est en ligne ?

Utilisateurs parcourant actuellement ce forum : Yahoo [Bot] et 3 invités

  •  Liens commerciaux