svchost.exe prend 100% de cpu au démarrage

Le Forum Windows XP

Messagepar benoitrousselot » 14 Avr 2007, 21:27

bonjour

Après pas mal de recherches et de tentatives infructueuses je viens chercher de l'aide :
sur windows XP au démarrage j'ai systématiquement un svchost.exe qui prend entre 60% et 100% de cpu. L'ordi est quasi inutilisable tant que je n'ai pas killé le process.
J'ai essayé de désactiver au démarrage la maj auto de windows, ainsi que certains autres services qui me paraissaient susceptibles de prendre de la cpu. Sans succès.
J'ai également passé plusieurs antivirus/spywares, rien d'inquiétant.

J'ai obtenu plus de détails sur le process coupable avec un process explorer :
C:WINDOWSSystem32svchost.exe -k netsvcs

Les services enregistrés auprès de ce process sont les suivants (obtenus avec Tasklist /SVC)
svchost.exe AudioSrv, Browser, CryptSvc, Dhcp, ERSvc,
EventSystem, FastUserSwitchingCompatibility,
helpsvc, lanmanserver, lanmanworkstation,
Netman, Nla, RasMan, Schedule, seclogon,
SENS, SharedAccess, ShellHWDetection,
srservice, TapiSrv, Themes, TrkWks, W32Time,
winmgmt, wscsvc, WZCSVC

Si quelqu'un a une idée ...
Merci d'avance.
benoitrousselot
 

Messagepar survivor » 15 Avr 2007, 08:01

bonjour

en moyenne les svchost.exe prennent environ 150 megs de mémoire vive etpeuvent sollciter fortement le cpu au démarrage, la charge en % dépendra de la puissance du cpu... sur le mien: core2 duo 6300 la charge oscille entre 0 et 2 % tous processus confondus aprés le démarrage.
Vérifie ça avec le gestionnaire de tâches, 2éme onglet :)
sed tantum dic verbo et sanabitur computerum meum
Avatar de l’utilisateur
survivor
Modérateur
 
Messages: 4054
Inscrit le: 18 Juil 2002, 10:14
Localisation: grand Nord

Messagepar JoShuA » 15 Avr 2007, 11:06

150 Mo ca fait quand même beaucoup j'atteins difficilement les 45 Mo
Avatar de l’utilisateur
JoShuA
Modérateur
 
Messages: 7246
Inscrit le: 02 Jan 2002, 15:37
Localisation: IdF

Messagepar survivor » 15 Avr 2007, 13:16

oui, mais j'ai inclus firefox, l'extension MCE, adwatch en résident etc. (39 processus entout) comme j'ai 2 gigas de ram ça ne me préoccupe pas :)
Dernière édition par survivor le 15 Avr 2007, 13:17, édité 1 fois au total.
sed tantum dic verbo et sanabitur computerum meum
Avatar de l’utilisateur
survivor
Modérateur
 
Messages: 4054
Inscrit le: 18 Juil 2002, 10:14
Localisation: grand Nord

Messagepar olivarum » 15 Avr 2007, 13:26

Bonjour à tous,

J'ai le même soucis et ce depuis l'install d'une carte réseau 3 Com et de la Live Box d'Orange avec 8 Méga (branchement en éthernet), mon pc est sous Xp pro avec un processeur Intel Pentium 4 de 1.8 GHZ et 512 MO de Mem RAM.
Auparavant, j'avais un simple modem ADSL avec 2 Méga (branché en USB), et aucun soucis, même lorsque je suis passé du forfait 2 Méga au 8 Méga, mon simple modem ADSL tournait à 12 Méga (peut être simplement en statique !!). Avec le routeur, il tourne à 7 Méga et le soucis du blocage totale du pc à cause du Svchot.exe du service réseau.
Petite question, combien doit-il y en avoir, car pour mon pc, j'en ai 4 (2 pour system, 1 pour service local et 1 pour service réseau) ?
Qu'en j'exécute la commande terminer le processus de Svchot.exe du service réseau, tout rentre dans l'ordre.
Y'a t'il un moyen pour empêcher le démarrage de ce processus au démarrage de windows

A bientôt, et bonne journée ensoleillé à tous. Image
olivarum
 

Messagepar neorule » 17 Avr 2007, 10:11

benoitrousselot a écrit:bonjour



Les services enregistrés auprès de ce process sont les suivants (obtenus avec Tasklist /SVC)
svchost.exe AudioSrv, Browser, CryptSvc, Dhcp, ERSvc,
EventSystem, FastUserSwitchingCompatibility,
helpsvc, lanmanserver, lanmanworkstation,
Netman, Nla, RasMan, Schedule, seclogon,
SENS, SharedAccess, ShellHWDetection,
srservice, TapiSrv, Themes, TrkWks, W32Time,
winmgmt, wscsvc, WZCSVC

En rouge c'est un trojan/backdoor

bon nettoyage.
neorule
 
Messages: 98
Inscrit le: 19 Mar 2005, 23:13

Messagepar olivarum » 20 Avr 2007, 22:02

benoitrousselot a écrit:bonjour


J'ai obtenu plus de détails sur le process coupable avec un process explorer :
C:WINDOWSSystem32svchost.exe -k netsvcs

Les services enregistrés auprès de ce process sont les suivants (obtenus avec Tasklist /SVC).

Bonjour,

Comment faites pour utiliser ces commandes, car pour la première je l'ai fait depuis la cmd exécuter et rien ne se passe et pour la seconde je ne sais pas ?

Merci pour votre aide

A bientôt
olivarum
 

Messagepar JoShuA » 20 Avr 2007, 22:48

neorule a écrit:
benoitrousselot a écrit:bonjour



Les services enregistrés auprès de ce process sont les suivants (obtenus avec Tasklist /SVC)
svchost.exe AudioSrv, Browser, CryptSvc, Dhcp, ERSvc,
EventSystem, FastUserSwitchingCompatibility,
helpsvc, lanmanserver, lanmanworkstation,
Netman, Nla, RasMan, Schedule, seclogon,
SENS, SharedAccess, ShellHWDetection,
srservice, TapiSrv, Themes, TrkWks, W32Time,
winmgmt, wscsvc, WZCSVC

En rouge c'est un trojan/backdoor

bon nettoyage.

Pas uniquement TrkWks.dll est le Distributed Link Tracking Client de Microsoft et est tout à fait légitime.
Avatar de l’utilisateur
JoShuA
Modérateur
 
Messages: 7246
Inscrit le: 02 Jan 2002, 15:37
Localisation: IdF

Messagepar olivarum » 22 Avr 2007, 15:19

Bonjour à tous,

Avec un peu de détermination et de courage (oui je suis encore un peu novice en info Image ), j'ai réussi à dresser la liste enregistrée de Svchost.exe avec Tasklist /SVC comme benoitrousselot. maintenant je saurais comment faire à l'avenir !!! Image

donc voici la liste au démarrage:

svchost.exe DcomLaunch, TermService, RpcSs, AudioSrv, Browser,
CryptSvc, Dhcp, dmserver, ERSvc, EventSystem, helpsvc,
lanmanserver, lanmanworkstation, Netman, Nla, RasMan,
Schedule, seclogon, SENS, SharedAccess, ShellHWDetection,
srservice, TapiSrv, Themes, TrkWks, W32Time, winmgmt, wscsvc,
wuauserv, Dnscache, LmHosts, RemoteRegistry, SSDPSRV,
WebClient, stisvc


et en voici la liste après avoir terminé manuellement et redémarré automatiquement le processus :

svchost.exe DcomLaunch, TermService, RpcSs, Dnscache,
LmHosts, RemoteRegistry, SSDPSRV, WebClient,
stisvc, EventSystem, helpsvc, Netman, Nla, RasMan,
Schedule, SENS, ShellHWDetection, TapiSrv, Themes, winmgmt

Voyez-vous quelque chose de pas normal dans cette première liste ? ce qui expliquerait peut être l'emballement du processus de l'ordre de 85 à 95% au démarrage en bloquant totalement mon pc et une fois le processus terminé, il redémarre normalement comme la seconde liste (sans redémarrage du pc, ni de la session)

Merci de votre aide.
Dernière édition par olivarum le 22 Avr 2007, 15:41, édité 1 fois au total.
olivarum
 

Messagepar olivarum » 01 Mai 2007, 10:59

Bonjour à tous,

Je reviens sur le sujet, hier j'ai lancé la CMD "CHKDSK c: /F/R" qui s'est effectuée durant 30 minutes au démarrage du pc, depuis le Svchost incriminé bloque moins longtemps mais est tout de même encore présent Image

Petite question, quelqu'un sait-il où peut se trouver l'historique d'analyse Image - s'il en existe une - de la cmd CHKDSK ? (pour mémoire j'ai Win Xp Pro SP2)

Merci de vos éventuelles réponses, à bientôt Image
olivarum
 


Retour vers Windows XP

Qui est en ligne ?

Utilisateurs parcourant actuellement ce forum : Google [Bot] et 4 invités

  •  Liens commerciaux



cron