Gros problème de partage d'application

Le Forum Windows Server 2003
Scanner Windows pour détecter les erreurs de registre

Ce que nous vous conseillons :

1. Lisez les réponses ci-dessous où vous trouverez des conseils et de l'aide de la part des autres utilisateurs.

2. Avant de faire des modifications sur votre système ou d'installer des logiciels, nous vous recommandons
    fortement de cliquer ici pour scanner Windows afin de détecter les erreurs de registre.



Messagepar beegees » 30 Mar 2005, 09:26

Bonjour le forum,



Je vous contacte car vous êtes mon dernier recours.



Cela fait maintenant plus d'une semaine que j'essaie de partager des simples didacticiels et je n'y arrive pas.



Ce sont des didacticiels créés avec Macromedia Authorware, je pense que ce sont des programmes 16 bits.



Je vous explique ce que je fais :



J'installe le didacticiel sur le serveur, le tout se copie automatiquement dans un lecteur réseau (pour pouvoir le partager).

Je copie ensuite le raccourci vers sysvol (le raccourci du didacticiel qui se trouve dans le lecteur réseau).



Chose importante, ces didacticiels se lancent à partir d'un Run-time.



Je lance donc le run-time, le runt-time se lance, il me donne la première page du didacticiel et quand je clique sur un bouton pour voir la première présentation, il me dit "There is no association for the file ». Pour un autre didacticiel j’ai ce message d’erreur « The file « Heart.rec » cannot be opened because the following error has occurred : no such file or directory”.



En voyant ces deux messages d’erreur, je me dis qu’il ne peut pas trouver les fichiers associés au didacticiel mais seulement la première page avec les bouton.



C’est comme un lien sur une page internet, lorsque qu’on clique sur le bouton, une page s’ouvre ou une action s’éxécute, ici rien.



Ce que j’ai essayé aussi c’est d’installer le programme en local (sur la machine cliente) en le mettant dans All user, Documents partagés et en donnant les droits nécessaires (contrôle total pour être sure). En local ça fonctionne, quand je me connecte sur le domaine avec la machine cliente et que j’appuie deux fois sur le raccourci (dans all user…) il me donne le même message d’erreur.



Je sais que Windows Server 2003 possède un serveur d'application, pensez-vous que cela serait la solution, avez vous une autre idée pour partager ces didactciels qui fonctionnaitent en réseau sous Windows NT 4 Server / Workstation et qui fonctionne en local sous Windows XP et Windows Server 2003.



J’èspère que quelqu’un pourra m’aider car c’est une partie très importante de mon boulot. Si je n’arrive pas à partager ces applications, les étudiants ne pourrons pas suivrent les cours normalement.



Merci d’avance pour votre aide.



David
beegees
 
Messages: 17
Inscrit le: 04 Fév 2004, 13:09

Messagepar Thanatos » 01 Avr 2005, 01:22

La mon pti gars, je pense que ta joyeuse applis point recherche le Heart.rec dans un endroit que tu soupconne meme pas...

la seule idée pour savoir où elle est perdus est l'excellent filemon de Mr Russinovich... http://www.sysinternals.com/ntw2k/source/filemon.shtml

tu peut aussi regarder où est le 'start in' de ton 'shortcut'

et enfin pourquoi diable tu copie ca dans Sysvol ?? hooo sysvol c'est les policies, et les login script le reste -> DEHORS,) esaye donc de mapper un share plutot

Allez courrage

ps : oui il y a fortes chances que ca marche en serveur d'application mais vus le budjet des licences Cal, ca me paraits hors de portée de l'etudiant ,)
Every One has his own day to DIe....
Thanatos
 
Messages: 274
Inscrit le: 29 Mai 2002, 21:11
Localisation: Devant Mon Clavier

Messagepar beegees » 05 Avr 2005, 11:53

Thanatos a écrit:La mon pti gars, je pense que ta joyeuse applis point recherche le Heart.rec dans un endroit que tu soupconne meme pas...

la seule idée pour savoir où elle est perdus est l'excellent filemon de Mr Russinovich... http://www.sysinternals.com/ntw2k/source/filemon.shtml

tu peut aussi regarder où est le 'start in' de ton 'shortcut'

et enfin pourquoi diable tu copie ca dans Sysvol ?? hooo sysvol c'est les policies, et les login script le reste -> DEHORS,) esaye donc de mapper un share plutot

Allez courrage

ps : oui il y a fortes chances que ca marche en serveur d'application mais vus le budjet des licences Cal, ca me paraits hors de portée de l'etudiant ,)

Bonjour,

Merci pour ta réponse.

Pour le programme Heart, j'ai trouvé la solution, j'ai mis les utilisateurs du domaine en utilisateurs avec pouvoir (bouton droit de la souris sur Poste de travail/Gérer/groupes/utilisateurs avec pouvoir/utilisateurs du domaine) et cela à fonctionné.

Je présume donc que le programme Heart devait avoir accès à quelque chose (registre...) que l'utilisateur standart ne pouvait atteindre.

Je suis très intéressé par ta réponse. Je vais essayer de me documenter sur le programme que tu me conseilles car j'ai encore deux ou trois programmes qui ne fonctionnent toujours pas.

Voici un message que j'ai laissé sur un autre forum :

Bonjour le forum,

J'ai toujours ce problème de partage d'applications.

J'ai réussi (avec l'aide de Jonathan que je ne remercierai jamais assez) d'en exécuter quelques unes.

Ce qu'il faut savoir c'est que ces appilcations ont toutes des extensions différentes et celles qui me posent problèmes ont les extentions .app

Ce sont des didacticiels crées avec Authorware de Macromedia.

J'ai installé ces didacticiels en local. Quand je lance le fichier principal qui est GPILEUM.FBL il me lance le auto-run


Etant donné que je n'arrive pas à le partage à partir du serveur, je me suis dis qu'il serait pas mal de le lancer à partir de la machine locale, j'ai donc donné les droits de lecture et exécution à tout le monde, une fenêtre me demande de mettre mon login et mot de passe (ce qui me confirme que même les utilisateurs du serveur y auront droit).


Lorsque je me connecte sur le serveur, je vais dans c: j'ouvre le dossier ou ce trouve le didacticiel, je clique deux fois sur GPILEUM.FBL et j'obtiens bien le run time


Quand je clique sur un bouton il me donne ce message d'erreur "There is no association for the file"


Ce dont je suis (presque) sure c'est que :

- Ce n'est pas à cause d'une GPO ni d'un profile car j'ai créé un nouveau user (bidon) sans GPO, sans profil.
- J'ai mis Admins du domaine à un utilisateur avec lequel je me suis connecté et j'ai essayé d'ouvrir l'application avec cet utilisateur mais rien n'y fait.

Donc en local ça fonctionne, je donne tous les droits nécessaires, je vais en domaine et là le run-time s'ouvre mais on dirait qu'il ne trouve pas les fichiers liés aux différents boutons.

J'ai donné les droits sur le dossier complet, les fichiers et sous-dossiers héritent des droits du dossier.

Quelqu'un aurait-il un soupçon d'idée qui pourraît m'aider à sortir de ce pétrin.

J'ai essayé d'êre le plus claire possible mais si vous avez des questions, n'hésiter pas à me contacter.

Merci d'avance.

David

Qu'en penses-tu ?

C'est complètement dingue qu'en local ça fonctionne et en domaine ça fonctionne pas.

Merci d'avance pour ton aide.
David
beegees
 
Messages: 17
Inscrit le: 04 Fév 2004, 13:09

Messagepar beegees » 05 Avr 2005, 11:54

Thanatos a écrit:La mon pti gars, je pense que ta joyeuse applis point recherche le Heart.rec dans un endroit que tu soupconne meme pas...

la seule idée pour savoir où elle est perdus est l'excellent filemon de Mr Russinovich... http://www.sysinternals.com/ntw2k/source/filemon.shtml

tu peut aussi regarder où est le 'start in' de ton 'shortcut'

et enfin pourquoi diable tu copie ca dans Sysvol ?? hooo sysvol c'est les policies, et les login script le reste -> DEHORS,) esaye donc de mapper un share plutot

Allez courrage

ps : oui il y a fortes chances que ca marche en serveur d'application mais vus le budjet des licences Cal, ca me paraits hors de portée de l'etudiant ,)

Bonjour,

Merci pour ta réponse.

Pour le programme Heart, j'ai trouvé la solution, j'ai mis les utilisateurs du domaine en utilisateurs avec pouvoir (bouton droit de la souris sur Poste de travail/Gérer/groupes/utilisateurs avec pouvoir/utilisateurs du domaine) et cela à fonctionné.

Je présume donc que le programme Heart devait avoir accès à quelque chose (registre...) que l'utilisateur standart ne pouvait atteindre.

Je suis très intéressé par ta réponse. Je vais essayer de me documenter sur le programme que tu me conseilles car j'ai encore deux ou trois programmes qui ne fonctionnent toujours pas.

Voici un message que j'ai laissé sur un autre forum :

Bonjour le forum,

J'ai toujours ce problème de partage d'applications.

J'ai réussi (avec l'aide de Jonathan que je ne remercierai jamais assez) d'en exécuter quelques unes.

Ce qu'il faut savoir c'est que ces appilcations ont toutes des extensions différentes et celles qui me posent problèmes ont les extentions .app

Ce sont des didacticiels crées avec Authorware de Macromedia.

J'ai installé ces didacticiels en local. Quand je lance le fichier principal qui est GPILEUM.FBL il me lance le auto-run


Etant donné que je n'arrive pas à le partage à partir du serveur, je me suis dis qu'il serait pas mal de le lancer à partir de la machine locale, j'ai donc donné les droits de lecture et exécution à tout le monde, une fenêtre me demande de mettre mon login et mot de passe (ce qui me confirme que même les utilisateurs du serveur y auront droit).


Lorsque je me connecte sur le serveur, je vais dans c: j'ouvre le dossier ou ce trouve le didacticiel, je clique deux fois sur GPILEUM.FBL et j'obtiens bien le run time


Quand je clique sur un bouton il me donne ce message d'erreur "There is no association for the file"


Ce dont je suis (presque) sure c'est que :

- Ce n'est pas à cause d'une GPO ni d'un profile car j'ai créé un nouveau user (bidon) sans GPO, sans profil.
- J'ai mis Admins du domaine à un utilisateur avec lequel je me suis connecté et j'ai essayé d'ouvrir l'application avec cet utilisateur mais rien n'y fait.

Donc en local ça fonctionne, je donne tous les droits nécessaires, je vais en domaine et là le run-time s'ouvre mais on dirait qu'il ne trouve pas les fichiers liés aux différents boutons.

J'ai donné les droits sur le dossier complet, les fichiers et sous-dossiers héritent des droits du dossier.

Quelqu'un aurait-il un soupçon d'idée qui pourraît m'aider à sortir de ce pétrin.

J'ai essayé d'êre le plus claire possible mais si vous avez des questions, n'hésiter pas à me contacter.

Merci d'avance.

David

Qu'en penses-tu ?

C'est complètement dingue qu'en local ça fonctionne et en domaine ça fonctionne pas.

Merci d'avance pour ton aide.
David
beegees
 
Messages: 17
Inscrit le: 04 Fév 2004, 13:09

Messagepar beegees » 06 Avr 2005, 12:25

Salut Jonathan,

Je viens avec du neuf !

J'ai installé le programme sur un autre PC.

J'étais dans une session administrateur.

J'ai lancé le programme et il a fonctionné !

Je suis revenu comme client, j'ai lancé le programme et boum "There is no
association for the file" c'est donc pour moi un problème de droit.

Je me demande si un des composants (programme ou fichier) ne serait pas
autoriser à être ouvert.

Autre chose :

Hier on m'a conseillé d'utilsié un programme qui s'appelle filemon.

Lorsque j'ouvre le programme "Cells", il me dit exactement ou il va chercher
les infos.

J'ai vu qu'il y'avait un access denied ou quelque chose dans le genre.

Je vais voire en détail ce qu'il se passe et je te tiens au courrant.

Pour résumer, j'ai installé le programme sur un autre PC, en administrateur
il fonctionne, en client il fonctionne pas, donc problème d'autorisations
?????

Thanks to you !

David
beegees
 
Messages: 17
Inscrit le: 04 Fév 2004, 13:09

Messagepar Thanatos » 07 Avr 2005, 19:42

et remercions aussi Mr Mr Russinovich pour le Regmon qui fait la meme chose pour la registry aussi sur le meme site....
Every One has his own day to DIe....
Thanatos
 
Messages: 274
Inscrit le: 29 Mai 2002, 21:11
Localisation: Devant Mon Clavier

Messagepar beegees » 08 Avr 2005, 09:07

J'ai trouvé !!! et je dois cela à Thanatos , je te remercie donc encore une fois !

J'ai lu dans un livre qu'il existait un programme qui s'appelle "regmon".

Je l'ai donc téléchargé et ce programme m'a beaucoup aidé car j'ai pu me rendre compte qu'une chaine app n'existait pas dans le registre, donc impossibilité d'ouvrir les fichiers avec l'extention app.

J'ai donc créé une nouvelle chaine, mis le chemin du programme c:APWrunapw2.exe ^.app et quand j'ai appuyé sur un bouton, ça c'est lancé !

J'ai donc résolué 90 % du problème !

Je dis 90 % car maintenant je n'arrive pas à mettre cette chaîne pour chaque utilisateurs du domaine.

J'ai pourtant créé un nouveau profil ou cette chaîne apparaît mais quand j'attribue le profil à un utilisateur, la chaine n'apparâit pas dans le regeidt.

Quelq'un aurait l'amabilité de me dire comment je pourrais faire pour ajouter cette chaine :

app avec cette valeur : c:APWrunapw2.exe ^.app

à ce niveau du registre :

HKEY_CURRENT_USERSoftwareMicrosoftWindows NTCurrentVersionExtensions

Je vous dis tout de suite que j'ai déjà essayé de le mettre dans :

HKEY_LOCAL_MACHINESoftwareMicrosoftWindows NTCurrentVersionExtensions

mais ça marche pas, ça devrait pourtant se répertorier sur chaque utilisateur Image

Enfin voilà, je vais encore essayer.

Merci à tous et surtout à Thanatos.

Bg's
beegees
 
Messages: 17
Inscrit le: 04 Fév 2004, 13:09

Messagepar PITCHOUNE74 » 08 Avr 2005, 15:01

Salut

Tu peux utiliser les scripts d'ouverture de session des utilisateurs.

Dans ton script tu ecrit la clé dans la base de registre.
et la plus de pb. :P
PITCHOUNE74
Administrateur Système sur Windows 2003 Server

2 sites
4 serveurs 2003
200 postes clients en XP Pro
PITCHOUNE74
 
Messages: 18
Inscrit le: 23 Déc 2003, 15:48
Localisation: Annecy

Messagepar beegees » 08 Avr 2005, 15:05

PITCHOUNE74 a écrit:Salut

Tu peux utiliser les scripts d'ouverture de session des utilisateurs.

Dans ton script tu ecrit la clé dans la base de registre.
et la plus de pb. :P

Salut,

Merci pour ton message.

C'est ce que j'essaie de faire.

Voici mon script mais ça marche pas.

Tu vois quelque chose d'anormale ?

Merci

Code: Tout sélectionner
reg ADD HKEY_CURRENT_USER.SoftwareMicrosoftWindows
NTCurrentVersionExtensions /v app /t REG_SZ /d
^%systemroot^%runapw2.exe^app
beegees
 
Messages: 17
Inscrit le: 04 Fév 2004, 13:09

Messagepar Thanatos » 08 Avr 2005, 17:57

Image Les policy les mec les policy c aussi fait pour .....

Pour rajouter une clef c'est bien, pensons policy... lancon la secte des policy addicts !!!!
Every One has his own day to DIe....
Thanatos
 
Messages: 274
Inscrit le: 29 Mai 2002, 21:11
Localisation: Devant Mon Clavier

Messagepar PITCHOUNE74 » 08 Avr 2005, 19:08

tu peux créer un fichier .reg

puis dans ton script ecrire un truc du style:

regedit /s "chemin d'acces au fichier reg" Image

regedit /s permet de fusionner automatiquement ton fichier reg avec la base de registre
Dernière édition par PITCHOUNE74 le 08 Avr 2005, 19:10, édité 1 fois au total.
PITCHOUNE74
Administrateur Système sur Windows 2003 Server

2 sites
4 serveurs 2003
200 postes clients en XP Pro
PITCHOUNE74
 
Messages: 18
Inscrit le: 23 Déc 2003, 15:48
Localisation: Annecy

Messagepar beegees » 09 Avr 2005, 17:13

PITCHOUNE74 a écrit:tu peux créer un fichier .reg

puis dans ton script ecrire un truc du style:

regedit /s "chemin d'acces au fichier reg" Image

regedit /s permet de fusionner automatiquement ton fichier reg avec la base de registre

Bonjour,

J'ai trouvé !!!

Voici ce que j'ai mis :

reg add "HKCUSoftwareMicrosoftWindows NTCurrentVersionExtensions" /v app /t REG_SZ /d "c:apwrunapw2.exe ^.app"

Bon Week-End

Bg's
beegees
 
Messages: 17
Inscrit le: 04 Fév 2004, 13:09

Messagepar beegees » 09 Avr 2005, 17:14

Thanatos a écrit:Image Les policy les mec les policy c aussi fait pour .....

Pour rajouter une clef c'est bien, pensons policy... lancon la secte des policy addicts !!!!

Policy, tu parles des GPO ???

Désolé pour mon ignorance, je suis un grand débutant Image

Bon Week-End

Bg's
beegees
 
Messages: 17
Inscrit le: 04 Fév 2004, 13:09

Messagepar Thanatos » 10 Avr 2005, 16:31

patiente, j'me fend d'un HOwTO Image
Every One has his own day to DIe....
Thanatos
 
Messages: 274
Inscrit le: 29 Mai 2002, 21:11
Localisation: Devant Mon Clavier

Messagepar beegees » 12 Avr 2005, 08:25

Thanatos a écrit:patiente, j'me fend d'un HOwTO Image

Cool Image

Fais moi signe quand il sera fait !

Merci pour tout.

Bg's
beegees
 
Messages: 17
Inscrit le: 04 Fév 2004, 13:09

Suivant

Retour vers Windows Server 2003

Qui est en ligne ?

Utilisateurs parcourant actuellement ce forum : BingBot [Bot] et 1 invité

  •  Liens commerciaux



cron